Ein System Problem?

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Ein System Problem?

      Ich grüße euch.
      Ich leite mal kurz einen link zu dem Artikel meines Gmod Forum Artikels weiter da sich dort gar nichts bewegt. :|
      Das Problem ist dort von mir ziemlich genau Dargestellt worden.
      Vielleicht kann man mir hier helfen.
      Link: gmod.de/threads/37382-HL%C2%B2…oder-Face-Tool-Fehlerhaft
      Ich habe alles getan was mir eingefallen ist, aber dieser Fehler ist eigenartig da er sich jeder Art von Vorgehen wiedersetzt.. ?(
    • Ok soviel dazu....
      Ich erkläre es jetzt mal deutlicher.

      Bild Nr.01#

      Wie man hier sieht sind bis auf zwei Regler alle in der Standard Ausgangsposition
      Die Zwei befinden sich also schon bei Aktivieruung des Tools in einer Fehlerhaften Position
      Auch erkennt man das das Gesicht des Ragdolls ebenfalls nicht auf Normal steht.

      Bild Nr02#

      Hier haben wir die Gleiche Situation jedoch in der externen Faceposer Anwendung die sich im bin Ordner des Garrys Mod und Half Life² Verzeichnes befindet.
      Der Unterschied ist hier das die Fehlerhafte Ausgangsposition keine direkte Auswirkung hat


      Bild Nr03#

      Dies ist die Fehlermeldung die schon kurz nach dem Laden der Flatgrass Map in der Entwicklerkonsole zu lesen ist mit der ich jedoch nicht viel anfangen kann.
      Ich vermute allerdings das es da einen Zusammenhang gibt.


      Dieser Fehler sorgt dafür das bei allen Ragdolls die auf Basis der HL² Modelle aufgebaut wurden,
      die Mimik entweder sehr beschränkt oder garnicht veränderbar ist.
      Dazu kommt das sich das Problem jeder Art der Gegenmaßnahme wiedersetzt.
      Die Bilder stammen aus dem Letzten Versuch im absoluten 0 Zustand.
      Keine anderen Source Games, Keine abonierten Addons im Workshop oder im Dateiordner.
      Ergo gibt es nichts was da einen Einfluss auf die HL² Engine ausüben könnte.
      Der Test mit der Face Poser Anwendung habe ich sowohl mit der in dem Garrys Mod Verzeichniss als auch mit dem in HL².
      In Beiden Fällen trat der gleiche Fehler auf.
      Auch ein vollständiges Löschen der gesamten Source Spiele [deinstall und löschen aller Dateien] erbrachte auch kein ergebniss.

      Ich hoffe diese ziemlich genaue Ausführung des Problems ist jetzt klarer.
    • Das sollte recht einfach sein einfach den Ordner hier brauchst du.
      common\GarrysMod\sourceengine\scripts
      Also Scripts kopieren, dann in
      common\GarrysMod\garrysmod\scripts

      Kann auch anders herum sein bin da nicht mehr sicher aber einer von den beiden Ordner ist oft nicht da.
      Also dann den einen Scripts Ordner zu dem Anderen kopieren oder neuen erstellen falls noch nicht vorhanden..

      In dem Ordner ist die Kinect SDK die benötigt wird um Faceposer zu laden.

      PS:

      Ich denke, meine Lösung könnte da eventuell helfen bin aber nicht 100%tig sicher!
      Sonst falls keiner der beiden Ordner existiert einfach mal Source SDK unter tools in Steam laden.

      Mit freundlichen Grüßen,
      Peridotpower
    • Ja das wollte ich bezwecken mein Trick lässt das Tool auf jedenfall arbeiten.
      Wenn die Engine noch nicht läuft hätte ich da mehrere Lösungsansätze die man versuchen könnte:

      Übrigens denke die 3. Möglichkeit ist am besten jedoch daurt sie am längsten also entscheide du.
      1. Installiere dir mal folgene Tools dirket über steam auf die selbe Festplatte wie Gmod Source SDK // Source SDK Base 2006 // Source SDK Base 2007
      Die dort enthaltenden Datein sind die Basedatein der Source Engine, sie sollten zwar eigentlich schon bei Gmod dab
      ei sein aber wie bei Script bereits gesehen weiß man ja nie.

      2. Geh auf Steam dann Bilbliotek dann Gmod (rechtsklick) eigenschaften Updates dann nimmst du den Haken bei Steam
      Cloud synchronisation raus (Die Steamcloud speichert sehr oft nur bei Gmod Fehler also z.b. Defekte workshopobjekte
      oder halbe lua codes dies passiert immer wenn das spiel beim speichern abstürtzt// um dies auszuschließen einfahc den Haken wegnehmen bei Cloud Synchronisation und Neuinstallieren.
      Danach wenn es gelöscht ist nachsehen ob alles im gmod ordner weg ist gegebenenfalls löschen dann neuinstallieren
      . Dann wieder den Scriptsordner kopieren ja dann geht es vieleicht.

      PS:Ich hatte übrigens das selbe Problem bei hat aber das mit dem Scripts-Ordner schon geholfen.

      3.
      Mach ein textdokument falls nochnicht vorhanden in den bin Ordner:

      Quellcode

      1. "enginetools"
      2. {
      3. "library" "tools/commedit.dll"
      4. "library" "tools/pet.dll"
      5. "library" "tools/vmt.dll"
      6. }






      Die Datein sollten auch da sein!
      Sonst habe ich noch nen Code geschrieben der es vieleicht fixen könnte:Dann einfahc das Folgende machen:

      C-Quellcode

      1. @echo off
      2. :: Batch file to launch Faceposer with proper environment
      3. :: Confirm VPROJECT variable is set
      4. call "%~d0%~p0check_sdk_env.bat"
      5. :: Launch Faceposer
      6. echo Starting Faceposer...
      7. echo Executing "%~d0%~p0hlfaceposer.exe" %*
      8. start "" "%~d0%~p0hlfaceposer.exe" %*


      nenne diese batch einfach Faceposer.bat

      dann mach noch ne batch in den bin Ordner und nenne diese :"check_sdk_env"
      und packe den Code rein:

      Quellcode

      1. @echo off
      2. if "%VPROJECT%"=="" (
      3. if exist "%~d0%~p0set_sdk_env.bat" (
      4. call "%~d0%~p0set_sdk_env.bat"
      5. ) else (
      6. echo WARNING: VPROJECT not set, and set_sdk_env.bat file not present.
      7. pause
      8. )
      9. ) else (
      10. echo VPROJECT=%VPROJECT%
      11. )
      Alles anzeigen
      Dann nocheine Machen mit dem namen "set_sdk_env.bat"

      alles in bin ornder tun und den Code drauf machen

      Quellcode

      1. @echo off
      2. echo Configuring Source SDK environment variables for Half-Life 2
      3. :: Set local environment variable that will only persist in processes
      4. :: created by the current command processor shell
      5. SET VPROJECT=%~d0%~p0..\hl2
      6. :: Commentthis out if you ant to set it permanently as a system variable,
      7. :: too
      8. :: echo Attempding to set VPROJECT in system environment
      9. :: SETX VPROJECT %VPROJECT%
      10. :: echo.
      11. echo VPROJECT=%VPROJECT%
      Alles anzeigen
      Jetzt einfach nur noch die erste Batch also Faceposer.bat ausführen im Bin ordner fertig.




      So das Wars sind jetzt ein paar tricks die vieleicht helfen könnten
      Bitte achte nicht auf meine Rechtschreibung, die ist schrecklich :D #einfach drauflosschrieben

      Mit freundlichen Grüßen,
      Peridotpower

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von PeridotPower ()

    • Alle drei Batches sind vorhanden,
      SDK 2013 Single und Multiplayer instaliert
      und dennoch
      Auch in der Garrys Mod selbst gabs keine Auswirkung.
      Moment habe da was gefunden....



      Habe jetzt alle SDK Versionen installiert....
      Batches alle da wo sie sein sollen.
      Effekt...nada
      Was es auch ist,
      es wiedersetzt sich echt jeden Versuch es zu fixen.

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von XALORR ()

    • Habe es nochmal von Anfang an gemacht Deisntall, Löschung alleer Daten und alle Schritte genaustes wiederholt.
      Ergebnis:

      Kann echt nicht normal sein oder?

      Die Batches habe ich in
      C:\Program Files (x86)\Steam\steamapps\common\GarrysMod\garrysmod\bin
      verfrachtet.
      Hatte angenommen das es vielleicht da funktioniert aber wie du siehst hat es auch nichts gebracht.
      Zusatz: Habe jetzt auch die 'enginetools' Batch datei erstellt und in den bin Ordner gespeichert als auch
      die anderen drei wieder dorthin zurück gelegt, jedoch auch ohne weiteren Effekt.

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von XALORR ()

    • Ubdate:
      dritter Versuch mit Scriptordner und Batchdatei ohne Ergebnis durchgeführt.
      Ich habe jetzt GM mal deinstalliert und restlos gelöscht dafür HL² installiert.
      Jetzt kommt der Witz;
      Die Fehlfunktion betrifft auch die Faceposeranwendung dort, ohne den Einfluss von GM.
      Deine Lösungsvorschläge hätten mit Sicherheit funktioniert Peridot,...
      [Danke nochmals dafür.]
      ...wenn sich das Problem auf GM begrenzen würde.
      Aber irgendwie ist der Fehler unabhängig von beiden Games vorhanden.
      Was diesen Fehler verursacht es liegt nicht an GM ansich.
      Kann man irgendwie die Clouddaten löschen?
      Werde jetzt zu drastischen Maßnahmen greifen und Steam vollständig von der Platte putzen.

      Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von XALORR ()

    • Unmöglich Fassbar
      Ich habe gestern Steam vollständig deinstalliert, alles dahingehend von der Platte geputzt.
      Heute habe ich Steam wieder installiert und ausnahmslos GM installiert.
      Und dennoch ist desser vertrackter Fehler noch immer vorhanden. Oo

      Das einzige was mir da noch einfällt ist das ich an die Cloud Daten kommen muss um den Fehler eventuell dort zu löschen.
      Daher jetzt meine Frage:
      Wie kommt man an diese Daten?
    • War ja das erste was ich nach dem Neuinstall von Steam, gemacht habe.
      Ich verstehe nicht wie dieser Fehler derart permanent sein kann.
      Egal was ich versuche, nichts schlägt an.
      Ich habe auch die Batch Dateien in beiden Bin Ordner eingefügt.
      Sogar den ganzen Source Engine Ordner habe ich kopiert und in den Garrys Mod Ordner eingefügt.
      Absolute Nada
      Es ist so als würde ich egal ob Half Life oder GM den Fehler mit runter laden.
      Deswegen fragte ich ja ob ich irgendwie die Cloud Daten löschen kann, falls sich dort der Fehler befindet.
      Ganz Ehrlich so ein fest gefressen Fehlfunktion ist mir noch nie untergekommen.
    • Ich wollte durch Powershell die Ordner aus der Cloud löschen, aber dafür braucht man die Remote Dateien und die existieren in den entsprechenden Ordnern der Garrys Mod nicht.
      Naja neuer Account? Das spiel ist nicht gratis...leider.
      In dem Fall kann ich auch das spiel von meinem Account löschen und neu kaufen.
      Der Fehler trat einfach so auf.
      während ich gerade was an bearbeiten war..poof..fehlfunktion.
      Und seid dem geht es einfach nicht mehr weg.
      Und ja bei anderen Ragdolls funktioniert das Tool ohne Probleme,
      das ist ja das verwirrende.
      Ich schätze mal das diese zwei hier nicht auf dien standard HL² Modelle basieren.
      Leider aber der Hauptteil scheinbar schon.